ImageGreetings! Welcome to Tezzaworld website, unfortunately you are a few years late to the show as nearly everyone has been and gone, there is still lots of useful archived material to read through, not many active users unfortunately, but that’s the way it goes, hopefully you are not too disappointed...

Standard Stereo not working.

For all your audio/visual & general interior needs, post here
Rikochet
Trc On!
Posts: 32
Joined: Wed Nov 02, 2011 5:06 pm

Standard Stereo not working.

Postby Rikochet » Thu Mar 26, 2015 8:07 pm

OK I just bought my '98 Altezza and noticed during the 6 hour drive home that the stereo wasn't working! It was advertised as having a sat nav (dated Panasonic one which only worked once) DVD/TV player (removed prior to sale) and CD player. My intention is to eventually rip out all the dodgy wiring and electronics and just have a basic CD head unit with my touchscreen sat nav in the pop up display.

Right now though I have no sounds as I can't get the standard stereo to power up. I initially thought it was gubbed but when I was looking at the pics the seller sent me before the sale I noticed that the lights were all on.

Checked the radio fuse in the drivers foot well and it looks to be intact. Is there anything else I might be missing? Pretty sure there was a space in the box under the bonnet for another relay. Is this the likely culprit?

Return to “I.C.E & Interior section”

Who is online

Users browsing this forum: No registered users and 1 guest

cron