Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Erratic idle

Any problems with your Altezza, post questions here
ThatGuy
Trc Off
Posts: 103
Joined: Mon Sep 21, 2015 9:50 pm
Location: Camberley

Erratic idle

Postby ThatGuy » Sat Feb 06, 2016 7:02 pm

So my tezza was running perfectly fine a little while ago, and then it all went downhill. When it's cold it seems to run okay but when it's up to temperature the idle is all over the place, even ti the point where it will drop down so low and stall. (which has happened multiple times)
The only thing that has changed is my flywheel to a solid one, and when I was in the engine bay, I knocked the coolant hose to the throttle body thermostat and broke the hose connector off. So at the minute I've just bypassed the thermostat by running the hose from the inlet straight to the outlet on the block.
Would this be the cause of my problem? I have seen people say that when the thermostat is dirty it can mess up the idle and make it all over the place, so that makes me think it's that.
I've tried everything else like clean the maf (and even swapped it for my spare one with no effect) and reset the ecu.
And help would be awesome :)

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Erratic idle

Postby Tosh21 » Wed Feb 17, 2016 9:06 pm

I doubt its the flywheel, light flywheels do have some effect on idle but it would do it all the time.

how have you bypassed the stat? I dont quite get what you mean. if you miss the stat (by runing without it) then it wont make a difference, youll just never get to temperature.


erratic idle seems to be a very common thing with these cars. Mine drops really low when its warm and stalls for no aparent reason. do you not have any coolant going to the TB anymore or did you replace that?

ThatGuy
Trc Off
Posts: 103
Joined: Mon Sep 21, 2015 9:50 pm
Location: Camberley

Re: Erratic idle

Postby ThatGuy » Thu Feb 18, 2016 9:00 am

By bypassing it I mean that where there's usually a coolant hose going to the throttle body from the engine block, I've taken it off the throttlebody thermostat and just connected it to the return line on the block so it completely misses out the throttlebody thermostat altogether.
I have got a new TB thermostat on its way and new coolant lines to it so I'm hoping that with sort the problem as I've seen loads of people say that if your idles all over the place then it can be the thermostats just got dirt on it which can mess it up, but I'll report back when I've fitted it :)
But in the mean time I've just turned my idle up to stop the car from stalling

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Erratic idle

Postby Tosh21 » Fri Feb 19, 2016 7:32 am

ohh i thought you meant engine thermostat. I thought the thing in the throttle body was just to heat the body up to stop it freezing?

ThatGuy
Trc Off
Posts: 103
Joined: Mon Sep 21, 2015 9:50 pm
Location: Camberley

Re: Erratic idle

Postby ThatGuy » Fri Feb 19, 2016 1:18 pm

That was pretty much what I got from researching about it, but some people have said that if it's dirty then it can mess with the idle.
But that's the only thing on the engine I've touched recently so I'm hoping that replacing it will help solve the problem :)


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: Bing [Bot] and 4 guests