Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

My First Build

Once you've introduced yourself why not throw up a few pictures of your car or a project thread?
User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Fri Sep 26, 2014 10:55 pm

more problems!

Welded a bung on the sump for the turbo return

Image

Look nice in there

Image

Feed and return, looks racey! Didn't realize how low the sump was to the ground though

Image

Finally got to fire it up and started of ok for a few seconds.spools very fast. However after a while I started to get some oil out the back of the turbo.

Image

Such a pain in the ass. I've got a -8 fitting as the drain because the turbo has a -8 fitting on the bottom so I presumed it would be enough. I'm hoping that it is the drain being too small an not leaking seals. Oil pressure did sit quite high so I think it is the drain. Will drill out the middle of the fitting as much as I can and hope for the best. Going to get the return as vertical as I can too just to rule that out completely should it still leak

Soiled
Altezza Guru
Posts: 705
Joined: Sat Dec 11, 2010 3:35 pm

Re: My First Build

Postby Soiled » Fri Sep 26, 2014 11:39 pm

Silly question.... But have you made the return line above where the oil sits while running? If not the oil won't come down that return line easily.

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Sat Sep 27, 2014 6:46 am

Its as high on the sump as I could go. But the sump is tiny I think the oil actually sits higher than the sump when full. I'm gonna try tap into a return somewhere else and see what happens

Soiled
Altezza Guru
Posts: 705
Joined: Sat Dec 11, 2010 3:35 pm

Re: My First Build

Postby Soiled » Sat Sep 27, 2014 8:55 am

There is an oil return on the block under the exhaust manifold, tee into that.

User avatar
hermit
Trc Off
Posts: 112
Joined: Sat Aug 24, 2013 2:56 pm

Re: My First Build

Postby hermit » Sat Sep 27, 2014 2:54 pm

Image

Is that the pipe to the right of the manifold you're talking about soiled?

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Sat Sep 27, 2014 3:57 pm

I hope so cos that's where I've gone to lol

Soiled
Altezza Guru
Posts: 705
Joined: Sat Dec 11, 2010 3:35 pm

Re: My First Build

Postby Soiled » Sat Sep 27, 2014 6:22 pm

Yeah that's it.

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Fri Oct 10, 2014 10:40 pm

Exhaust sitting pretty nice. It sits a bit further in now but It's nice and hidden away. Not a fan of exhausts that are right in your face with massive tips.

Image

Underneath

Image

Turned down a blanking panel for the turbo. Have to keep the exhaust housing on while the rest is away for rebuild. There is no way to join the tubes so closely unfortunately. Works really well though. Car is pretty slow and there is literally NO bottom end whatsoever which is expected from a 4-1 but I think the turbo housing stalls the gasses a bit.

Image

Planned to go to a show on sunday and do some track time but mot ran out so I worked 5-5.30 the next day on monday, 5-9 tuesday, 5-2.30 then 5-12.30 thursday.

Mot today and it failed...on horn not working! Totally gutted

No pic but I put some 20mm spacers under the bonnet on the hinge to raise the back of the bonnet and cut some of the strengthening out otherwise the turbo won't fit and it works incredibly well for keeping the engine bay cool and doesn't look too bad. The bonnet does wobble a fair bit though.

Trd Shane
Tezza Fanatic!
Posts: 232
Joined: Mon Dec 02, 2013 10:44 pm
Location: Dublin

Re: My First Build

Postby Trd Shane » Thu Oct 16, 2014 7:55 pm

Your some fabricator lad fair play
"If it can't be fixed with a hammer it's an electrical problem"

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Sun Nov 23, 2014 10:53 am

Been pretty busy recently so not done much work but got a fuel return all sorted.

New walbro 255. Turns out I got the wrong one, its a tiny bit longer than standard so I just took the filter off and moded it a little. Just gota make sure I don't let the fuel get too low to be on the safe side.

Image

Soldered the new plug for the walbro and used some fuel proof shrink wrap so it never has a fault.

Image

Welded the standard regulator.

Image

Fitted adjustable regulator. Little titanium bracket to hold it because I had some ti so why the hell not. Full cheapo spec ebay job regulator so it will be going in the bin asap. Just used it so I could see if that was the issue with the poor starting.

Image

Stainless hardline under the car with AN-6 fittings welded on the ends.

Image

Return into the pump.

Image

Pretty happy with the results, seems to have solved the problem. Getting a sard regulator after payday.

Manifold is coming off next week too for a redesign. Going to lose the collector I made and go into a straight tube collector so that I can drop the turbo lower.

Water gets under the bonnet so some ghetto leak repair until I get the manifold off.

Image

Also got an intercooler. Subaru WRC, good for 4 bar

Image

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Sat Nov 29, 2014 12:59 am

I decided to redo my manifold while I had the chance so cut it up and managed to save most of the bends thankfully

Image

Cleaned up pretty nice!

Next I got onto making a collector. Instead of going for the usual collector with the bends and slip joints which is good for flow and fit but it is incredibly tall I decide to make a little stubby collector with straights.

Image

Getting pretty good at these now!

Image

Thought it looked nice, the welds all coming together in the middle

User avatar
RS Tom-Hundred
Tezza Fanatic!
Posts: 450
Joined: Fri Nov 28, 2014 3:31 pm
Location: Cambridgeshire

Re: My First Build

Postby RS Tom-Hundred » Wed Dec 03, 2014 2:13 pm

Great work mate and some cracking fabricating! Keep it up and us all updated :)

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Fri Dec 19, 2014 12:37 am

Been incredibly busy working flat out on the car after work trying to get her back on the road before Christmas.

Manifold is FINALLY done after 60 hours. Almost. Very light and pretty dam sturdy but it will droop after a hard drive when it gets real hot so will be bracing it.

Image

Priced it up out of curiosity and it's worth just over £3000. Good thing I can make this stuff myself!

Fitted one of my dead turbos (I have somehow managed to accumulate 2 turbos, good to have spares :closedeyes:) and the bonnet now closes which is good. Moded the downpipe to fit the new turbo location too.

Image

Next was to deal with the issue of space. Seem to always be dealing with this issue. Nowhere to put the wastegate so I moved the battery to the boot s the wastegate can take up some of that space.

Image

No such thing as too much ali tape!

Battery in the boot, no strap yet because I may be getting a nice gel battery. Fitted it with anderson connectors, makes it so easy to disconnect the battery for working on electrical parts or leaving the car standing for weeks.

Image

Got myself a nice fuel pressure regulator too.

Image

Have a 5 bar electronic pressure sensor so after I set it with an analogue gauge I will wire up an electronic one (if I can) so I can have a FP gauge in the car for ultimate bling.

Will be in on the weekend to smash out some more bits and get this car running asap.

Starting to really miss the rough ride, random noises and the ridiculously deep low exhaust note.

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: My First Build

Postby Tosh21 » Wed Dec 24, 2014 6:05 pm

Made a brace for the manifold to try stop it drooping too much. Even though it's inconel it will still droop a little and over time, Probably won't work but it's better than nothing.

Image

Gone full retard and started to strip the interior.

Image

Battery strap, looks a bit gash tbh but does the job it's pretty dam sturdy

Image

FPR mounted and set.

Image

Cut out the bracing to get the intercooler pipes in

Image

Little brace made up as the top panel was so dam flexible it was going all over the place and the bonnet wouldn't shut

Image

Intercooler mounts off the chassis arms, pretty dam sturdy. Also a little PAS cooler mounted, had to lose the old one as it was too big to fit.

Haven't had a chance to drive it yet unfortunately as the PAS wouldn't fully bleed so need to have a look at that when I'm back but it's looking good!

Just needs a turbo delete pipe, more interior stripped and intercooler pipes made and it will just be waiting for some money for an ecu and map.

User avatar
chewse
Trc Off
Posts: 192
Joined: Mon Jul 15, 2013 5:14 pm
Location: Vieux-Fort, St.Lucia

Re: My First Build

Postby chewse » Wed Dec 31, 2014 1:01 pm

woowww


Return to “Member's Cars / Projects”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests