Page 1 of 1

Altezza cranks but not starting

Posted: Thu Jun 16, 2016 10:42 am
by Steve86
Hie Guys.
Just last night when l was leaving from work, my tezz could not start but its cranking. What could be the problem?.

As always, thanks for the feedback

Re: Altezza cranks but not starting

Posted: Thu Jun 16, 2016 1:58 pm
by nenaghcorolla
battery id say not enough power in it to start the car used to have this problem with my one and got a bigger battery and no prob since

Re: Altezza cranks but not starting

Posted: Wed Jun 22, 2016 2:48 pm
by Steve86
Thanks Nenagh for your response, unfortunately l found out it was a dirty injector..car runs fine now...

But to be honest im NOW so dissapointed with this Site, gettin only one response a week since l posted this which l thought, and still think is not a rocket science problem. Truely speaking, l verily miss the good old days when we had guys like Mike_01, Noel, Damok, RS Tom-Hundred, Jarocki only to mention a few, when this site was still very useful that l could barely spend a day without gettin online to see what was happening. Things have changed, one gets more than 20 views and a single or no reply for a problem, this is absolutely not the REAL TEZZWORLD I knw...I am SO dissapointed, we have lost the lustre of the site, lets get back to the old ways where helping each other was a norm, not a rarity like this......

:cry: :cry: :cry:

Re: Altezza cranks but not starting

Posted: Thu Jun 23, 2016 8:23 am
by jarocki
Hello.

Yes i have been very quiet on the site as of late. Having owned the car for 8 years and counting it seems very hard to own an altezza these days. Insurance costs for cars over 15 years and a japanese inport is just making owning the car an effort. 8 years ago was a different story altogether. Glad you got the car sorted anyway.

Re: Altezza cranks but not starting

Posted: Thu Jun 23, 2016 8:56 am
by Steve86
Thank you Jarocki, l understand your situation.

To other guys who still own their tezzas, lets keep up the brotherly spirit of helping each other.

Re: Altezza cranks but not starting

Posted: Thu Jun 23, 2016 9:46 am
by ThatGuy
I know what your saying I try to chime in where I can but my knowledge of altezzas is abit limited. But I agree it's really annoying when your post a problem and don't get a response for weeks :/

Re: Altezza cranks but not starting

Posted: Mon Jun 27, 2016 10:36 am
by RS Tom-Hundred
I'm still here but unfortunately Ive been busy lately and not checked the forum for a while. I try to get on when I can though.

This was always gonna eb a tricky one to diagnose as it could be one of many things either power, fuel, spark or air related! Guessing you got all the basics checked and it turned out to be fuel.

Did you get a new injector or could it be cleaned/saved to solve the issue in the end?

Re: Altezza cranks but not starting

Posted: Thu Jul 14, 2016 3:09 pm
by SilTezza
+1.. i felt the same way too.. the forum been quiet for sometimes..