Page 1 of 1

Turbo Altezza cutting out when warm

Posted: Fri Dec 04, 2015 10:44 am
by WatkinsDW
So Ive recently had an engine conversion done on my Altezza. Had old 3sge engine removed, with another 3sge engine put in with turbo extras. apexi ecu and handcontroller.

The garage who has done it have managed to get it up and running sweet but only when cold. They said it revs up nicely and gets some decent boost until the point of it getting warm. Once the engine has warmed up they said it just dies down and eventually leads to cutting out. They have checked the usual things like plugs coilpacks leads and stuff for moisture.

They did say when they originally turned it over the first time lots of fuel was dumping out exhaust so they reduced the fuel flow with the hand controller then got it running sweet. But like i said that's only when cold. Any advice would be great.

Thanks

Re: Turbo Altezza cutting out when warm

Posted: Fri Dec 04, 2015 11:26 am
by Soiled
Sounds very much like a common fault with the powerfc, search here and altezzaclub.org.nz, has happened to many turbo Altezzas with the same ecu.

I've had it for many years it comes and goes, can be months or a year without doing it then have a few days of doing it every few kilometers. Have sent it away found nothing. *shrug*

Re: Turbo Altezza cutting out when warm

Posted: Fri Dec 04, 2015 11:52 am
by WatkinsDW
Dam, i was thinking of maybe taking it to get a custom remap and hopefully get it diagnosed same time, problem is i might have to get it towed up there.

Re: Turbo Altezza cutting out when warm

Posted: Wed Mar 16, 2016 6:47 pm
by turbotezza
i take it fuel pump and fuel pump relay was checked