Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Power Steering Whine

Post info/questions on engine mods and issues here
okolatsis
Trc On!
Posts: 31
Joined: Tue May 27, 2014 12:42 pm

Power Steering Whine

Postby okolatsis » Fri Aug 07, 2015 12:21 pm

Hi All,

My car has develped a loud whine from cold. There is fluid in the reservoir, does anyone know how I can drain the system so that I can put some new fluid in? Is there anything else to check why it might be making this whine?

On another note, i had issues with the car running badly and not engaging VVTI, i cleaned out the MAF and the car is like new nowm pulls strong and hard.

Thanks in advance

Rio

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Power Steering Whine

Postby Tosh21 » Sat Aug 08, 2015 8:17 am

To drain just undo pull off the rubber hose on the return side and it Wil pour out. then you need to turn the wheel full lock left to right a few times until nothing else comes out .do it in the air it's much easier. Just be careful though cos quite alot will come out.

I'm not sure about a cold fluid whine but it normally means the pump is on the way out

okolatsis
Trc On!
Posts: 31
Joined: Tue May 27, 2014 12:42 pm

Re: Power Steering Whine

Postby okolatsis » Mon Aug 10, 2015 3:22 pm

Thanks Tosh, Return side, this is the end that's on the pump or the reservoir?

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Power Steering Whine

Postby Tosh21 » Tue Aug 11, 2015 12:02 pm

find the hose that goes to the top of the reservoir and follow it back to the rack, should join on the passanger side of the rack .That's the return hose

okolatsis
Trc On!
Posts: 31
Joined: Tue May 27, 2014 12:42 pm

Re: Power Steering Whine

Postby okolatsis » Tue Aug 11, 2015 1:30 pm

usually after about 10mins the noise goes away but today it was constant, I think the pump is about to die, I will try a flush tonight to see if it works

Going by the attached its the pipe labeled 44412D that attaches underneath the reservoir, I will take this off correct?
Attachments
Capture.JPG
Capture.JPG (50.66 KiB) Viewed 380 times

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Power Steering Whine

Postby Tosh21 » Wed Aug 12, 2015 11:08 pm

I can't remember what a standard setup looks like now but I think that's the one. You couldcrack off a fitting on the rack itself,might struggle to catch the fluid if you take that hose off. I'll get a pic tomorrow if it's dry enough outside but it sounds more like your pump is on the way out. I had new fluid in mine last year and it's whining now after getting too hot from the exhaust manifold being so close


Return to “Engine & Transmission section”

Who is online

Users browsing this forum: No registered users and 2 guests