Page 1 of 2

struggles to start and diesels

Posted: Fri Nov 14, 2014 10:21 pm
by Tosh21
Car cranks for quote a while before it actually fires. I think it's only when cold though, I'm not sure I keep forgetting to pay attention to it.

Also when I turn her off it runs on for a while. It's not so bad when cold but after its warmed up to operating temp it's way more noticeable. I reckon it's hot spots in the cylinders. The head was fully rebuilt properly and skimmed flat (just a clean skim, no real thickness removed) so the engine should be pretty mint

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 12:15 am
by twiglett-RS200
what plugs are you using?
any way you can check ignition timing/ valve timing?

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 8:38 am
by peter0991
What exactly happened before this problem started?

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 8:58 am
by Tosh21
The ngk plugs that are recommended for the altezza. Pretty sure timing is right I spent a week checking it cos I was so worried I got it wrong. I'll run a timing gun on it next week anyway just to be sure.


It's done it as long as I can remember. Well, I think so anyway. I only drove it home from buying it before changing plugs so I can't remember if it did it before changing them. But that's only the rubbing on issue. It used to start really well but now, out of nowhere it just cranks for a few seconds.

I did have coilpack 2 fail on me and cylinder 2 plug seems to get dirtier than the others if that means anything

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 11:53 am
by Soiled
I notice a big difference in cranking time depending on the charge of my battery. Try putting your battery on a charger and getting it back up to full and see if it makes a difference.

As for turning off, not sure on that one... Leaky injector, plus lower octane fuel so the compression and residual heat is enough to ignite it? How long after you turn the key off does it run for?

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 12:46 pm
by Tosh21
The battery is fairly new though. Ill try put some more earths on see if that helps. It used to have loads but they were all big heavy speaker cable b I hated the way it looked. I'll see what the charge on the battery is too.

I only use v power. Or whatever the highest octane I can find If there's no shell garage. It's very noticeable if I turn it off it kinda chugs itself to a stop. My other car stops instantly when I shut off

If fuel was getting in after shut down surely it should not fire? It shouldn't be hot enough to fire without a spark surely.

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 1:31 pm
by Trd Shane
Tosh21 wrote:The battery is fairly new though. Ill try put some more earths on see if that helps. It used to have loads but they were all big heavy speaker cable b I hated the way it looked. I'll see what the charge on the battery is too.

I only use v power. Or whatever the highest octane I can find If there's no shell garage. It's very noticeable if I turn it off it kinda chugs itself to a stop. My other car stops instantly when I shut off

If fuel was getting in after shut down surely it should not fire? It shouldn't be hot enough to fire without a spark surely.



This is probably useless info but mine kinda did that took longer to start and when knocking off it would chug a bit .. But when I installed power fc that all stopped .. It starts on the button and doesn chug ?? Dunno if that helps man ??

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 8:18 pm
by Tosh21
Oh really? Maybe the standard map doesn't like my mods. How is the pfc anyway? Got it all sorted and running?

Re: struggles to start and diesels

Posted: Sat Nov 15, 2014 8:39 pm
by Trd Shane
Tosh21 wrote:Oh really? Maybe the standard map doesn't like my mods. How is the pfc anyway? Got it all sorted and running?


Possibly :/ ??
Yeah got it fixed lad and up and running just need a map now but smashed after getting it fixed hahha
Thanks again pal

Re: struggles to start and diesels

Posted: Sun Nov 16, 2014 12:58 am
by twiglett-RS200
i sold my turbo altezza and when i bought it back the wiring under the dash had been f*** about with so it used to run on. sometimes the only way to stop it was to pull the key out.
i think it was still getting a feed from the ignition barrel on the acc position.

Re: struggles to start and diesels

Posted: Sun Nov 16, 2014 8:57 am
by Tosh21
twiglett-RS200 wrote:i sold my turbo altezza and when i bought it back the wiring under the dash had been f*** about with so it used to run on. sometimes the only way to stop it was to pull the key out.
i think it was still getting a feed from the ignition barrel on the acc position.



Youb may be onto something actually. My alarm goes off quite often and it comes back with an ignition fault. Like its getting power to ignition without a key. I'll have a look at all that after I check the timing too

Re: struggles to start and diesels

Posted: Mon Nov 17, 2014 12:30 pm
by Tosh21
Tried pulling key straight out and it still runs on. It chugs and bucks a bit as it hits the last 2 or so revs and I could hear the fuel pump last night still making noise after shutdown. I normally can't hear it at all. Can't hear it now during normal driving either but that's probably because the exhaust is loud.

Really struggled to start yesterday too. Cranking for ages, eventually fires butreally struggles . Almost chokes and the revs drop low then quickly it's totally fine again.

Could it be a dying pump? Pumping fuel in when it shouldn't hence the running on and struggling to start because it's just not managing to pump the fuel very well. Or even losing fuel rail pressure?

Re: struggles to start and diesels

Posted: Mon Nov 17, 2014 10:06 pm
by Tosh21
The starting issue I've narrowed down to a fuel leak somewhere. I fitted my regulator with return but blocked off the return so I could use it just as a gauge for now. On crank it tries to build pressure and jumps straight to 2 ish bar, stays there a bit while it cranks more then goes up again and then fires. It then holds a steady pressure on idle (didn't try revving but that shouldn't change it anyway should it?) What is the standard fuel rail pressure on this car?

After I turn off, the pressure holds a little bit (i think its due to the pump still going for a couple of seconds) then drops pretty dam fast.

Must be a leak somewhere no? The rail pressure should be maintained at all times shouldn't it. Unless the car has been Sat for weeks.

Not sure why it runs on yet, will see if engine shop have a way of testing injectors for leaks

Re: struggles to start and diesels

Posted: Tue Nov 18, 2014 9:23 am
by peter0991
Check your compression man

Re: struggles to start and diesels

Posted: Tue Nov 18, 2014 8:04 pm
by Tosh21
Narrowed it down to injectors being fine. The rail holds pressure but the fuel line does not. It doesn't build pressure when you turn key to ignition either. I think the regulator is goosed so I will sort out my fuel system and that shouldbe it .

Running on I think is actually from the idle being too high. It's at 2k when warm. When I've sorted my fuel system I will drop the idle and try it. 90% sure that's it. It's been doing it for 6k miles now so if it was hot spots I'm sure I'd have had a big problem by now