Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Radiator problem.

Any problems with your Altezza, post questions here
auatezza
Noob!
Posts: 15
Joined: Thu Jun 09, 2011 4:22 am
Location: Aruba

Radiator problem.

Postby auatezza » Sat Nov 05, 2011 5:28 am

Hi my altezza radiator is broken.
Where can I get one ?Does the one of lexus is300 fit?

ryansss
Tezza Fanatic!
Posts: 215
Joined: Tue Mar 01, 2011 7:23 pm

Re: Radiator problem.

Postby ryansss » Sat Nov 05, 2011 10:16 am

In what way is it broken?

I think the the Is300 the pipework at bottom is the wrong way round so will need a longer custom hose. I'm sure someone will correct me if I'm wrong.

User avatar
jarocki
Altezza Guru
Posts: 1420
Joined: Thu Mar 12, 2009 4:49 pm
Location: Dublin

Re: Radiator problem.

Postby jarocki » Sat Nov 05, 2011 11:31 am

nick is selling radiators at good price email him

User avatar
tomo
Altezza Guru
Posts: 1127
Joined: Fri Jul 17, 2009 3:10 pm
Location: Poole, Dorset

Re: Radiator problem.

Postby tomo » Sat Nov 05, 2011 8:35 pm

Yer it's either genuine one or an alloy one for less money than genuine one from nick the site trader.
Image

lackneramanda
Trc On!
Posts: 42
Joined: Tue May 03, 2011 8:13 am

Re: Radiator problem.

Postby lackneramanda » Tue Jan 17, 2012 4:33 am

auatezza wrote:Hi my altezza radiators is broken.
Where can I get one ?Does the one of lexus is300 fit?


Hey guys, I've been trying to get my car to pass the referee this past month. I've done everything he has told me to besides fixing my radiator fan. The previous owner wired the fan motor to my cigarette lighter because it wasn't cycling previously. I need it to cycle it on and off because this dude is being a hard ass.

Any ideas on what could be wrong? I've looked at the diagram on my haynes manual and have been studying that. I'm a complete novice when it comes to anything electrical. I do have a/c but no a/c hoses but all the wires should be connected.

Is a job like this very hard? Any help will be appreciated. thanks

User avatar
jezza
Trc On!
Posts: 29
Joined: Tue Nov 01, 2011 5:03 pm
Location: Glasgow

Re: Radiator problem.

Postby jezza » Tue Jan 17, 2012 9:33 am

Have you checked the sensor in the bottom of the radiator. I'm sure thats what switches the fan on at the appropriate temperature. You can check if the fans are working by unplugging the coolant temp sensor. Green plug above power steering pump.


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 2 guests