ImageGreetings! Welcome to Tezzaworld website, unfortunately you are a few years late to the show as nearly everyone has been and gone, there is still lots of useful archived material to read through, not many active users unfortunately, but that’s the way it goes, hopefully you are not too disappointed...

power enterprise supercharger isuue

Any problems with your Altezza, post questions here
User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

power enterprise supercharger isuue

Postby yamahatezza » Tue Oct 19, 2010 4:11 pm

Hi bought a used power enterprise supercharger, installed the kit, should run 6psi and it makes only 2.3 psi by 4000rpm then after 5000rpm it starts dropping off then eventually genereates a vacumme. very weird no boost leaks or intake leaks, charger is always driven no clutch so always turning.? any ideas who knows about super chargers, ? from 1000 - 4000rpm its torquey then after that all it has is the vvti - only made like 180 hp on the dyno very weird hmmm

not_too_fast
Trc On!
Posts: 25
Joined: Wed Sep 23, 2009 4:11 pm

Re: power enterprise supercharger isuue

Postby not_too_fast » Tue Oct 19, 2010 5:05 pm

Did you upgrade the injectors?
could be runnig too lean?

User avatar
Robin H
Southern England Rep
Posts: 2356
Joined: Sun Mar 18, 2007 10:23 pm
Location: Dorset
Contact:

Re: power enterprise supercharger isuue

Postby Robin H » Tue Oct 19, 2010 5:39 pm

Strange, is there anyone you can get to inspect the charger over to make sure its working correctly

There's a member in here WPC or WCP who's had experience with SC maybe able to help
Deals on Anodised Altezza parts.... cooling panels and battery bars..
Image

If you are a UK member and interested in club meets please sign up here:
viewtopic.php?f=6&t=7729


Please Support TezzaWorld
viewtopic.php?f=2&t=8309


Club stickers
viewtopic.php?f=16&t=8724

Blitz Turbo Altezza RS220
Image
I wish I had more time.....

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Tue Oct 19, 2010 7:07 pm

hi
#the car is fuelling perfectly checked on a wideband and on rolling road.

#struggling to find someone who will inspect it. i replaced the bearing on the housing as it had play and resealed the unit very simple set up its just a single speed gearbox with no clutch so cant see why it wont boost higher than 2.5 psi or start loosing boost from 4500rpm then slowly creating a vacumm. by 7000rpm

i have checked the seal i replaced twice it aint leaking, was thinking since at like 6000 rpm it makes full boost it might not if the throttle wasnt opened 100%? but dont know how the throttle system is operated on the rs200.


really stuck ?

not_too_fast
Trc On!
Posts: 25
Joined: Wed Sep 23, 2009 4:11 pm

Re: power enterprise supercharger isuue

Postby not_too_fast » Tue Oct 19, 2010 7:14 pm

boost in my car drops as well once ya get over 5k rpm... think thats normal, but not so that it starts a vaccum at 7k rpm

what pulley have you on the s/c? it could be from belt slippage...

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Tue Oct 19, 2010 7:38 pm

hi mate do you have a supercharged altezza? am running the standard 100 mm pulley. got a custom reduction pulley also but dont want to fit it untill i fix this issue, if the belt was slipping would i not notice as if this belt slips then so does the belt to my supercharger.

sparkystav
Trc Off
Posts: 148
Joined: Thu Mar 13, 2008 7:41 pm
Location: Lancashire, UK
Contact:

Re: power enterprise supercharger isuue

Postby sparkystav » Tue Oct 19, 2010 7:53 pm

i'd go with a slipping belt as well in my opinion. esp if your completely sure its not leaking
Image

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Tue Oct 19, 2010 8:12 pm

weird as the belt seems tight enough, would the slipping belt cause a vacumme? after a certain rev range 4500 rpm ish the bost slowly starts dropping then by 7000rpm its in vacumme weird?

not_too_fast
Trc On!
Posts: 25
Joined: Wed Sep 23, 2009 4:11 pm

Re: power enterprise supercharger isuue

Postby not_too_fast » Tue Oct 19, 2010 8:20 pm

yup, i have a blitz set up in my yoke..

check the alternator belt too

must you put oil in the compressor u have?

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Tue Oct 19, 2010 8:28 pm

no it get its oil pressure from the engine, crank drives a belt to the supercharger then the supercharger drives the altenator. all belts seem ok but will try and tighten them a bit n recheck boost pressure.

also my boost recirc valve has been checked and removed makes no difference.

anything else could cause this issue i am getting so hacked off spent a fortune on parts n get this so gutted hope i can fix this issue.

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Wed Oct 20, 2010 6:08 pm

well got a new belt set it as tight as i can, checked the pulley for tightness all ok still car only boosts 2.5 psi no sound or signs of leaks and boost starts dropping off above 5000rpm, what are my options who in the uk can check these over and replace parts etc.? so gutted feel like giving up spent so much time and money and this is what i get.

User avatar
donut46
Meath Rep
Posts: 2119
Joined: Sun Sep 07, 2008 8:55 pm
Location: navan co. meath
Contact:

Re: power enterprise supercharger isuue

Postby donut46 » Wed Oct 20, 2010 7:41 pm

in the uk id think that fensport would be your best bet they have done a few supercharged toyotas might be worth a shout lad??
QUALITAT ALTEZZA

Please Support Your Club
viewtopic.php?t=8309&f=2

TezzaWorld Car Stickers
viewtopic.php?f=16&t=8724&hilit=stickers

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Wed Oct 20, 2010 8:25 pm

Al try also think it's the same as rotrex chargers so might call them.

User avatar
yamahatezza
Tezza Fanatic!
Posts: 448
Joined: Thu Apr 08, 2010 11:05 pm

Re: power enterprise supercharger isuue

Postby yamahatezza » Sun Oct 31, 2010 9:05 am

Fixed with custom belt size delete my posts cheers

alexlegault
Noob!
Posts: 2
Joined: Sat Oct 02, 2010 3:55 am

Re: power enterprise supercharger isuue

Postby alexlegault » Sun Jul 10, 2011 7:07 pm

i am going to buy a second hand power enterprize kit.
can you please tell me how it runs?
does it run well now that you have fixed it?
how did you fix it?
are you running a oil cooler?
do you need a special ecu?
please reply
thanks
Alex Legault (panchsandesh2@hotmail.com)


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest