Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Couple of Things

Any problems with your Altezza, post questions here
User avatar
raffo
Altezza Guru
Posts: 821
Joined: Wed Mar 03, 2010 6:00 pm
Location: Meath

Couple of Things

Postby raffo » Fri Jul 16, 2010 11:58 pm

Just lookin for info or if anyone has had the same problems.

1 - Metal rattle in front left wheel or brake when hitting small bumps??? Brakes working perfectly tho.
2 - When turning right at slower speed there's a low grinding noise, again coming from the front right. Don't know if it's the bearing or possibly dodgy power steering pump????
3 - Stupid Question, but how would i know if my shocks are on their way out? Stock suspension but lately it seems to be taking small bumps very hard, a real thud can be heard like. Could worn tyres account for it or what's the best/easiest way to test my shocks, especially the front?

Ok, that's it for now :) . As usual ppl, any help or info really appreciated

User avatar
KaTaLy5t
Altezza Guru
Posts: 2611
Joined: Sat Nov 10, 2007 12:08 pm
Location: Wexford

Re: Couple of Things

Postby KaTaLy5t » Sat Jul 17, 2010 12:51 am

1. Check for any play in the lower ball joints, these are a common problem on the tez and it's serious if one fails. If the ball joints are ok then have a look and see if any of the other bushes are gone.

2. The bearing would make noise all of the time I'd say if it was on the way out, did you check the pads and discs for wear? If there's a lip on the outside edge of your discs then they're worn.

3. Have a quick look up in the wheel well, you might see oil leaking from the shocks or traces of oil around where the leak is. If the bumps seem a lot more harsh than they used to be chances are the shocks are on the way out.


Hope that helps

k900
Tezza Fanatic!
Posts: 412
Joined: Sat Apr 04, 2009 5:51 am
Location: east cork

Re: Couple of Things

Postby k900 » Sat Jul 17, 2010 10:49 am

the metal sounding rattle could be the clips that hold the pads in place or there's a metal sort of ring on the lower wishbone bushes. i got new clips last week but i haven't had a chance to fit them yet. i'll be doing sometime during next week so i'll let u know if they cure rattle.
my shock was making a dull thud/rattle and there was no oil leaking and shock felt fine.

User avatar
raffo
Altezza Guru
Posts: 821
Joined: Wed Mar 03, 2010 6:00 pm
Location: Meath

Re: Couple of Things

Postby raffo » Sat Jul 17, 2010 4:19 pm

Thanks guys,
All joints seem fine and doesn't seem to be any play other than a normal amount, braking is fine, pads & discs are fine too. Going to check the pad clips now and see if it improves anything. As for the shocks, there's no oil leaks or anything abnormal going on, they seem fine other than the hard thud going on :roll:

User avatar
raffo
Altezza Guru
Posts: 821
Joined: Wed Mar 03, 2010 6:00 pm
Location: Meath

Re: Couple of Things

Postby raffo » Sat Jul 17, 2010 5:08 pm

Update on the rattle ----- Turns out it was the bottom calliper sliding pin. The bottom ones have a rubber washer on them to stop such rattles, mine for some reason had expanded and was out of place, sorted now tho and no more rattle!!! :) .
That's 1 down :lol:


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest