Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Front lights ant working!

Any problems with your Altezza, post questions here
hegs14
Noob!
Posts: 1
Joined: Thu Dec 04, 2008 6:37 pm
Location: Meath

Front lights ant working!

Postby hegs14 » Thu Dec 04, 2008 6:48 pm

Hi all just wondering could anyone help me out, I have a rsz 01 tezza, and is fitted with standard hid low beams, they started turning themselfs off after a few mins but if i turned all the lights off and back on they turn back on, but now they ant working at all, i had a few lads look at them and they reckon the ballasts? on gone, there is power getting to the ballast and the bulbs are ok just wondering what or where could i go to get it fixed, thanks!!

User avatar
IS3_FTW
Tezza Fanatic!
Posts: 211
Joined: Fri Nov 21, 2008 5:32 am
Location: NorthWest USA

Postby IS3_FTW » Thu Dec 04, 2008 7:37 pm

So both lights dont work?

I would say, first try to use another bulb, to be sure its the ballast and not your bulbs. If its the ballast, then it would be cheaper to buy a new one, then rebuilt ballast. If the ballast is rebuildable.

Let me know where and what brand of ballast you go with. As I am looking for one as well.

EDIT:
Welcome and do an introduction 8)
SY IS3
Exterior ~JDM Full Aero Lip Kit ~Altezza Mesh Grill ~JDM Heads&Tails ~RX Antenna
Interior ~JDM Coin Tray ~Altezza Climate Ring ~2IS Knob
Performance ~SRT Intake ~Toyo Header&Ypipe ~Ltuned Exhaust ~Greddy EMU
Suspension ~AirRunner w/Dakota Digital ~Hotchkis F/R sways ~ProLex STB&Trunk Bar
Wheels ~iForged Aero's w/Nitto NeoGen's

User avatar
dlocko
Altezza Guru
Posts: 854
Joined: Wed May 28, 2008 11:05 am
Location: Dublin

Postby dlocko » Thu Dec 04, 2008 10:34 pm

wouldnt bother fixin ebay ur answer,if you need new ballasts
Image

User avatar
Evelyn
Moderator
Posts: 6062
Joined: Mon Sep 10, 2007 9:06 pm
Location: Galway
Contact:

Postby Evelyn » Fri Dec 05, 2008 10:12 am

If u can try them on another car first
Image

User avatar
KaTaLy5t
Altezza Guru
Posts: 2611
Joined: Sat Nov 10, 2007 12:08 pm
Location: Wexford

Postby KaTaLy5t » Fri Dec 05, 2008 2:43 pm

It's probably the ballasts. I'm an electrician and we get these kind of problems on big lights that they come on and then go off again and 9 times out of ten it's a ballast problem


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest