Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Power/Fuse problem?

Any problems with your Altezza, post questions here
NotoriousMib
Noob!
Posts: 12
Joined: Sun Nov 03, 2013 8:35 pm

Power/Fuse problem?

Postby NotoriousMib » Tue Mar 14, 2017 6:42 pm

Long story short guys, was doing some bulb changes on heater controls and changing stereo, and when I plugged everything back in it blew a shed load of fuses. I've checked them all and everything is back up and running apart from the following.

Heaters don't work now. They light up clock works but no response from the dials or switches,

Lost my trc and snow button function and abs lights is constantly on, think they will be linked.

And my fuel gauge has stopped. The light just flashes away and reads empty.

All these were working right before something went pop. I've been through all the fuses and all look fine can't see any obvious blown ones, should I be changing any in particular just in case? Any one any ideas? All help welcome as I'm kinda lost.

Cheers

ThatGuy
Trc Off
Posts: 103
Joined: Mon Sep 21, 2015 9:50 pm
Location: Camberley

Re: Power/Fuse problem?

Postby ThatGuy » Tue Mar 14, 2017 7:12 pm

I'm not sure what fuses are what but have you checked both fuse box's? Theres one in the engine bay and one in the passenger footwell.

So I take it you replaced the blown fuses? But if the abs light is on its probably worth sticking it on a diagnostics as im sure that would be telling you there's a fault of some kind.

Either way let us know how you get on :)

NotoriousMib
Noob!
Posts: 12
Joined: Sun Nov 03, 2013 8:35 pm

Re: Power/Fuse problem?

Postby NotoriousMib » Tue Mar 14, 2017 8:31 pm

Yeah I've been through all 3 of the fuse boxes-dunno why they aren't all in one place- and couldn't see anything. Would the diagnostics show up if there is a relay or anything away? Not really been anywhere to find out if traction control is kicking in or not. Will try machine and get back on again when I figure out what it says.

ThatGuy
Trc Off
Posts: 103
Joined: Mon Sep 21, 2015 9:50 pm
Location: Camberley

Re: Power/Fuse problem?

Postby ThatGuy » Wed Mar 15, 2017 8:53 pm

It won't tell you if a relay has gone but from memory when altezzas have a fault the dash will stick the engine management light on and flash the TRC light. But in sure I've read that it can just start flashing random things on the dash depending on the type of fault.

Good luck finding the problem I'm sure when you find it it'll be something small :)


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 2 guests