Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

TRC Off Light Blinking and the ABS light stays On

Any problems with your Altezza, post questions here
User avatar
Dirty_J
Noob!
Posts: 7
Joined: Fri Oct 24, 2008 7:26 pm

TRC Off Light Blinking and the ABS light stays On

Postby Dirty_J » Fri Oct 24, 2008 7:46 pm

Hey 2 all, it first started wen my front left lower ball joint gave out on me, the tire almost left me and the car drivin down the road. Luckily the lower control arm was able to drop on the inside of the rim to keep the tire in place till I stopped :? . I noticed wen the ball joint gave out, the TRC Off Light started Blinking and the ABS light stayed on. I got the two lower ball joints changed one time, to hopefully avoid any further problems in that area. Unfortnately after everything was put bak in place the TRC Off light continues to Flash while the ABS stays on, the car drives more or less the same, just that the traction cuts on and off, while it flashes. My braking seems normal, but the ABS light stays on. Any Ideas of how I can correct these two problems 8 :roll:.

Thanx in advance.

User avatar
Evelyn
Moderator
Posts: 6062
Joined: Mon Sep 10, 2007 9:06 pm
Location: Galway
Contact:

Postby Evelyn » Fri Oct 24, 2008 8:08 pm

Welcome.....Not sure but is there wires there for the abs & trc into the hub might have draged them apart when the ball joint failed on you, is there any wire left hanging or loose?

User avatar
Dirty_J
Noob!
Posts: 7
Joined: Fri Oct 24, 2008 7:26 pm

Postby Dirty_J » Fri Oct 24, 2008 8:21 pm

I did notice that a wire was somewhat slack, but it wasn't disconnected from anything, but I told the mechanic about it, wen he was repairing the ball joints, and he said that he tightened it, but it still flashes and the ABS light stays on, I will take the tire off again and double check it, just to b sure.

User avatar
Evelyn
Moderator
Posts: 6062
Joined: Mon Sep 10, 2007 9:06 pm
Location: Galway
Contact:

Postby Evelyn » Fri Oct 24, 2008 8:35 pm

Ya do that first, does the light only come on when you brake, I know it might sound like a stupid question, what are you doing when the light comes on?

User avatar
Dirty_J
Noob!
Posts: 7
Joined: Fri Oct 24, 2008 7:26 pm

Postby Dirty_J » Fri Oct 24, 2008 8:57 pm

Alrighty, I c that there r 2 wires wen I took the tire off, one goin to the brake pads, and the nex one goin to the back of the hub. The two are connected, but the one to the back of the hub, looks like it cud go on lil bit more :oops:. The TRC Off Light and ABS light come on as soon as I start the car, no need to press or do anything. :roll:

User avatar
Evelyn
Moderator
Posts: 6062
Joined: Mon Sep 10, 2007 9:06 pm
Location: Galway
Contact:

Postby Evelyn » Fri Oct 24, 2008 9:03 pm

The one going into the brakes will make a guess thats its a ware indicator for brake pads could be wrong it could be abs wire aswell.....
I still recon there something loose it only started to give trouble after the wheel came loose on it....

User avatar
Dirty_J
Noob!
Posts: 7
Joined: Fri Oct 24, 2008 7:26 pm

Postby Dirty_J » Fri Oct 24, 2008 11:22 pm

Alrighty, but whateva wire that iz 4 that goes to the brake pads, that wire iz secure, if anything I wud think it wud b the other wire, its still connected, it jus looks like it can go down a bit more. I jus pulled dat first wire that goes to the back of the hub all the way down and clamped it solid, and turned the car on, and the TRC Off iz still Flashing and the ABS is still on. Any more ideas? :roll:

User avatar
Dan
Site Admin
Posts: 3792
Joined: Sat Feb 24, 2007 3:43 pm
Location: Dublin

Postby Dan » Fri Oct 24, 2008 11:43 pm

there is no wear sensor on the altezza brake pads, just to let you know. as far as i know the trc only detects slip etc on the rear wheels

User avatar
markrs200
Limerick Rep
Posts: 516
Joined: Sat Mar 03, 2007 6:45 pm
Location: countylimerick

Postby markrs200 » Sat Oct 25, 2008 12:13 am

Its either a wire broken or loose going to the sensor on the hub .You could also need a new sensor as it could have been damaged .That sensor going onto the hub is your abs sensor .If there is a short in that wire or sensor it will bring on the abs and trc light as they are all linked.And while your abs light is on you have NO abs
02 rs200.full trd kit, 18 inch ultralite gt2,toms spoiler,cusco H braces front and rear,cusco front strut brace,stoptect front discs&pads,full hks exhaust& decat,hks pannel filter,ngk irridiumplugs,hid kit ,toms eye brows,jdm front lights with angel eyes,trd decals on doors,leather interior,apexi rsm,lg dvd,sat nav,trd fioor mats ,fast road clutch +lightened flywheel lowerned 40mm,falcon evo 4+ alarm trd rad +oil cap Cusco front & rear arb's 201.6 bhp+211 torque

User avatar
KaTaLy5t
Altezza Guru
Posts: 2611
Joined: Sat Nov 10, 2007 12:08 pm
Location: Wexford

Postby KaTaLy5t » Sat Oct 25, 2008 10:22 am

Yeah I'd go with markrs200 on that. It happened to a friend of mine that the cable going to the hub on the back wheel was damaged and the TRC would flash and the ABS light stayed on as soon as he'd turn the key. I just joined up the cable again in some connectors and the lights went off.

User avatar
Evelyn
Moderator
Posts: 6062
Joined: Mon Sep 10, 2007 9:06 pm
Location: Galway
Contact:

Postby Evelyn » Sat Oct 25, 2008 4:28 pm

The wire might look ok are you sure you connetion on the hub is ok

User avatar
Dirty_J
Noob!
Posts: 7
Joined: Fri Oct 24, 2008 7:26 pm

Postby Dirty_J » Thu Oct 30, 2008 1:52 am

Hey, thanx to all, I was able to take it to the mechanic, and he said that I wud need a new ABS Sensor. Hopefully wen I get that sorted out, I shud b bak and runnin properly. :D

User avatar
Evelyn
Moderator
Posts: 6062
Joined: Mon Sep 10, 2007 9:06 pm
Location: Galway
Contact:

Postby Evelyn » Thu Oct 30, 2008 11:20 am

Not sure will it solve ur problem, because ur trc light is still flashing...but let us know...

User avatar
markrs200
Limerick Rep
Posts: 516
Joined: Sat Mar 03, 2007 6:45 pm
Location: countylimerick

Postby markrs200 » Thu Oct 30, 2008 1:12 pm

It will evelyn there all on the one circut
02 rs200.full trd kit, 18 inch ultralite gt2,toms spoiler,cusco H braces front and rear,cusco front strut brace,stoptect front discs&pads,full hks exhaust& decat,hks pannel filter,ngk irridiumplugs,hid kit ,toms eye brows,jdm front lights with angel eyes,trd decals on doors,leather interior,apexi rsm,lg dvd,sat nav,trd fioor mats ,fast road clutch +lightened flywheel lowerned 40mm,falcon evo 4+ alarm trd rad +oil cap Cusco front & rear arb's 201.6 bhp+211 torque

User avatar
KaTaLy5t
Altezza Guru
Posts: 2611
Joined: Sat Nov 10, 2007 12:08 pm
Location: Wexford

Postby KaTaLy5t » Thu Oct 30, 2008 1:25 pm

Yeah Mark is right. If there's a problem with one then both lights will come on. By the way Mark do you some one called Pat Culhane from Askeaton?


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest