Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Stiff Accelerator Pedal

Any problems with your Altezza, post questions here
User avatar
donato
Trc Off
Posts: 75
Joined: Wed Nov 12, 2014 9:53 pm
Location: Bolton

Stiff Accelerator Pedal

Postby donato » Sat Jan 17, 2015 5:15 pm

Hi all,
I've currently got my Altezza and it has a stiff accelerator pedal. Now it only appears to be stiff when the engine is on, not when it's off. I presume it's something to do with the TRC? If i turn the TRC off, it doesn't make a difference. It doesn't make it slightly stiffer, but quite stiff. So it's getting quite difficult to get to the biting point on the clutch and sometimes slip the clutch.
Any help? :lol:

User avatar
donato
Trc Off
Posts: 75
Joined: Wed Nov 12, 2014 9:53 pm
Location: Bolton

Re: Stiff Accelerator Pedal

Postby donato » Sun Jan 18, 2015 11:46 am

I've taken off the cover to the TRC unit and greased up the gears. It all looked very dry in there.

I hope that's cured it!

User avatar
donato
Trc Off
Posts: 75
Joined: Wed Nov 12, 2014 9:53 pm
Location: Bolton

Re: Stiff Accelerator Pedal

Postby donato » Thu Mar 19, 2015 10:51 am

Issue is still persistent!

When the engine is off the pedal is soft, when the engine is on it stiffens up.

It's driving me nuts.

I've unhooked the throttle cable from the throttle body and moved it within it's sleeving and it seems to be fine whilst pressing the pedal so it's pointing me towards the throttle body unit itself.

Anyone else had any similar issues?

User avatar
Tosh21
Altezza Guru
Posts: 521
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Stiff Accelerator Pedal

Postby Tosh21 » Sat Mar 21, 2015 8:56 pm

only thing i can think of is maybe the vac line? there is a little vac hose under the throttle body


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest