ImageGreetings! Welcome to Tezzaworld website, unfortunately you are a few years late to the show as nearly everyone has been and gone, there is still lots of useful archived material to read through, not many active users unfortunately, but that’s the way it goes, hopefully you are not too disappointed...

Temperature gauge reading normal but no hot air??

Any problems with your Altezza, post questions here
beany252
Noob!
Posts: 2
Joined: Wed May 09, 2012 10:20 pm

Temperature gauge reading normal but no hot air??

Postby beany252 » Tue May 27, 2014 2:02 am

I have recently bought a new altezza and only tonight really noticed that after driving for Afew minutes the temperature gauge reads normal as do all the others but even with heat cranked up full the air coming out the vents is not hot? At best it isn't even luke warm!? Anybody any ideas I was thinkin maybe thermostat?

User avatar
Tosh21
Altezza Guru
Posts: 524
Joined: Mon Jan 20, 2014 10:12 pm
Location: Oxfordshire

Re: Temperature gauge reading normal but no hot air??

Postby Tosh21 » Tue May 27, 2014 6:53 pm

If the temp read normal then thermostat is fine, it would run pretty cold if thermostat was broke. It's the heater matrix mine did the same but only hot. Take off your glovebox and you will see a big white thing. Wish I took pics now! There is 2 little black boxes which turn the actuators to change the flaps from hot to cold. You will see what I mean when you get there, you can turn the car on and change the temperature and where the air blows out of you will see what I mean.

User avatar
robodirect
Trc On!
Posts: 34
Joined: Sun May 10, 2009 1:15 pm

Re: Temperature gauge reading normal but no hot air??

Postby robodirect » Thu Jun 26, 2014 7:32 pm

Had the same problem a while back.Behind the glove box you'll see the two units with moving/joining levers.On mine one of them had come away,It took a bit of time but found the 'arm' that was causing the issue then re-attached it,no probs since.Just test it before putting glove box etc back in. Also I reckon spinning the air controller/temp dials very fast is what caused the 'arm' to pop off in the first place

Goodluck with it
Always talk to strangers...they`ve got the nicest sweets!!!


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 3 guests