Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

power steering problem help wanted asap!!

Any problems with your Altezza, post questions here
kev-e10
Noob!
Posts: 10
Joined: Mon Nov 11, 2013 11:02 pm

power steering problem help wanted asap!!

Postby kev-e10 » Mon Nov 11, 2013 11:29 pm

My original pump shat itself from the seals goin in it so she lost all the fluid out of it, I went away and put another pump into it before putting in d pump I flushed out the system cause I noticed some iron fillings in d system. I then bled up the system by locking from side time side pump was working fine I went to drive the car and the steering started getting heavy and d pump stopped working, after this I got another pump and d very same thing happened pump working 100% once I went to drive it d pump stopped working again. After this I got a steering rack out of another altezza and still no joy. I even done a sr20 pump conversion on and d very same thing working fine until I went to drive it then it stopped working

I had d fluid reservoir out of d car took d top off and cleaned out d mesh to ensure it wasnt blocked so d pumps wouldn't be starved of oil I also took all d pipes out of d car to ensure they weren't kinked or damaged all they all seem fine, I am really at a dead loss here as what to do next any help would be much appreciated :)

kev-e10
Noob!
Posts: 10
Joined: Mon Nov 11, 2013 11:02 pm

Re: power steering problem help wanted asap!!

Postby kev-e10 » Tue Nov 12, 2013 7:20 pm

Surly someone can shine some light on this? :?:

Emperor
Trc On!
Posts: 39
Joined: Sun Sep 08, 2013 9:17 am

Re: power steering problem help wanted asap!!

Postby Emperor » Wed Nov 13, 2013 8:25 am

What about the electric motor on the rack?

kev-e10
Noob!
Posts: 10
Joined: Mon Nov 11, 2013 11:02 pm

Re: power steering problem help wanted asap!!

Postby kev-e10 » Wed Nov 13, 2013 7:03 pm

Emperor wrote:What about the electric motor on the rack?


Pretty sure there isn't a electric motor on d rack,

my altezza is a 4cly beams

User avatar
rnd_audio
Tezza Fanatic!
Posts: 466
Joined: Thu Sep 04, 2008 7:15 pm
Location: kildare/ newbridge
Contact:

Re: power steering problem help wanted asap!!

Postby rnd_audio » Wed Nov 13, 2013 7:12 pm

U should pull apart the pump and see what went worng with them. Ive scene racks feck up pumps but u have change them. What colour is the fluid coming out of the broken pumps?
Image

Tyres are evil and must be punished :)

kev-e10
Noob!
Posts: 10
Joined: Mon Nov 11, 2013 11:02 pm

Re: power steering problem help wanted asap!!

Postby kev-e10 » Wed Nov 13, 2013 8:00 pm

rnd_audio wrote:U should pull apart the pump and see what went worng with them. Ive scene racks feck up pumps but u have change them. What colour is the fluid coming out of the broken pumps?


I have pulled apart the pumps and they are all fecked on the main part underneath where d fins/blades are, the fluid coming out of d pumps is a slightly darker shade of red than the fluid go in.

I think I might try another rack and all the pipes from another altezza


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest