Page 1 of 1

Headunit Problems. HELP

Posted: Fri Jun 12, 2009 11:13 pm
by is.two.hundred
Hey all. In trouble yet again. After discovering that the last owner of my car decided to wire in the head unit himself using black tape i pulled it all out (as sparks jumped out at me) :roll:
I went on to e-bay and contacted the seller and as advised bought the correct lead. (No amp).
Got it today and hooked it all up.
THE PROBLEM..... I do have power as it will load and eject a CD but it will not power up to play CD or tuner. Its a very basic JVC Headunit

I have 2 pics attached. No1 unused plug laying there and No. 2 is the lead i received

Any ideas or has anyone come across this before?

Thanks in advance.

Re: Headunit Problems. HELP

Posted: Sat Jun 13, 2009 12:44 am
by Dan
cant really tell from the pics as they appear very small, so you plugged the lead you got on ebay into amp wiring loom and then into your new headunit wiring and your headunit still wont work properly?

if you press the power button on your headunit does the display flicker then go dull?

If you check the headunit wiring there should be a red and a yellow wires, if you connect the red to yellow and yellow to red that might give you the right power.

after that, check fuses maybe

Re: Headunit Problems. HELP

Posted: Sat Jun 13, 2009 1:28 pm
by podgie
i can tell ya how to power it without the by-pass lead, use the by-pass lead just for ya speakers, join the read and yellow wire on your headunit together and power of + of ya battery. then join the black wire to the car.

Re: Headunit Problems. HELP

Posted: Sun Jun 14, 2009 8:37 pm
by is.two.hundred
Hey guys. Havnt had a chance to try yere suggestions yet. But what i did do was take out the new lead because #1 the back light on the dash clock was staying on all the time, #2 i got out of the car and left the lights on and the buzzer didnt sound. I think i better wait till Monday and give the people i got the lead from a call. They promised good customer care :?: