Page 1 of 1

TRC OFF button fault??

Posted: Sun Jul 01, 2012 7:44 pm
by KillianoIS
when i push the TRC OFF button in my IS it wont switch off the system and no light comes on the dash.
i know the system itself is working and the snow control works also.
can anyone suggest what it might be and/or a possible remedy?

Re: TRC OFF button fault??

Posted: Sun Jul 01, 2012 7:56 pm
by Damok
Is the connection on the back ok!! Is there a bulb in the dash :?

Re: TRC OFF button fault??

Posted: Sun Jul 01, 2012 8:08 pm
by KillianoIS
yeah there is a bulb on the dash....
must check connection on back but dont really have the know how.

Re: TRC OFF button fault??

Posted: Sun Jul 01, 2012 8:56 pm
by antok
KillianoIS wrote:yeah there is a bulb on the dash....
must check connection on back but dont really have the know how.


To check your connection on the back of the button jus put your hand in underneath wher the buttons are over your ashtray and pull the surrounding for buttons and radio outward gently it's jus clipped in you will see the connectors behind their

Re: TRC OFF button fault??

Posted: Sun Jul 01, 2012 9:28 pm
by KillianoIS
Cheers I'll have a look there. It has an aftermarket head unit but I presume it'll pull out just the same

Re: TRC OFF button fault??

Posted: Sun Jul 01, 2012 10:06 pm
by KillianoIS
Sorted and tested! :) thanks lads

Re: TRC OFF button fault??

Posted: Mon Jul 02, 2012 7:21 am
by antok
No bother mate

Re: TRC OFF button fault??

Posted: Mon Jul 02, 2012 9:15 am
by Damok
was it a connection?

Re: TRC OFF button fault??

Posted: Mon Jul 02, 2012 10:40 am
by KillianoIS
Ya was loose connection..

Re: TRC OFF button fault??

Posted: Mon Jul 02, 2012 4:30 pm
by Damok
KillianoIS wrote:Ya was loose connection..


I was right :D