Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Clicking noise??

Want to know what to brakes/springs to buy?
User avatar
Dan
Site Admin
Posts: 3792
Joined: Sat Feb 24, 2007 3:43 pm
Location: Dublin

Clicking noise??

Postby Dan » Thu Oct 11, 2007 5:24 pm

Thought i posted this up before but couldnt find it anywhere. So im getting a clicking noise coming form where i think is the front drivers side caliper, it only happens the odd time and usually at low speeds when i brake and come to a full stop, i was thinking maybe it the pad moving in the caliper(maybe wrong ones were used previously) Anyone know what im talking about or has experienced the same issue, and have a possible solution? new pads on the way soon so maybe that might fix the problem!

User avatar
endapender
Altezza Guru
Posts: 842
Joined: Sun Mar 04, 2007 2:57 pm
Location: kerry

Postby endapender » Fri Oct 12, 2007 8:16 am

That happens on mine. Seems to be a common thing on altezza. Its the pad moving in the caliper from what i've heard. Its not dangerious just slightly strange to hear it

User avatar
Gerbo
Tezza Fanatic!
Posts: 235
Joined: Sat Mar 03, 2007 3:48 pm
Location: Meath

Postby Gerbo » Fri Oct 12, 2007 1:55 pm

I have that on the Celica aswell. It seems to be a Toyota issue. I read somewhere that they had developed an adhesive pad to hold the brake pad in place. I haven't asked about it anywhere for fear of being laughed at :lol:


I'm going to change the pads and shims and the retaining clip to see if it stops. In the meantime i'm going to turn up the radio :D

kenny
Trc Off
Posts: 90
Joined: Sat Apr 21, 2007 2:45 pm

Postby kenny » Sat Oct 13, 2007 10:08 am

It's the same on mine was wondering what the noise was :P

User avatar
Bobby
South East Rep
Posts: 822
Joined: Sun Apr 29, 2007 11:58 am
Location: south east

Postby Bobby » Sun Oct 14, 2007 4:29 pm

some copper grease on the back of the pad should stop it moving around. i have no problems wit mine :?
I BEG TO DIFF-ER!!

User avatar
Gerbo
Tezza Fanatic!
Posts: 235
Joined: Sat Mar 03, 2007 3:48 pm
Location: Meath

Postby Gerbo » Sun Oct 14, 2007 10:24 pm

Bobby wrote:some copper grease on the back of the pad should stop it moving around. i have no problems wit mine :?



Unfortunately it doesn't

User avatar
wee_dave
Trc Off
Posts: 153
Joined: Mon Jul 09, 2007 7:01 pm
Location: Fife
Contact:

Postby wee_dave » Mon Oct 15, 2007 7:44 pm

I was about 2 post up this lol, yup i get it on occasion too :lol:

User avatar
Z_Edition
Trc Off
Posts: 65
Joined: Wed Aug 15, 2007 5:33 pm
Location: Malaysia

Postby Z_Edition » Fri Nov 02, 2007 1:41 am

same here as well... :cry:
Image
POWER トヨタ アルテッツァ 3S-GE

User avatar
shakey
Altezza Guru
Posts: 789
Joined: Fri Apr 06, 2007 8:20 pm
Location: tarbert co.kerry ireland
Contact:

Postby shakey » Fri Nov 02, 2007 1:53 am

happens on mine when im braking and turning


Return to “Brakes and Suspension”

Who is online

Users browsing this forum: No registered users and 2 guests