Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Search found 58 matches

Go to advanced search

by wenguin
Wed May 27, 2015 5:34 pm
Forum: Problems with your Altezza
Topic: Hesitation, I'm stumped
Replies: 7
Views: 721

Re: Hesitation, I'm stumped

I'm not 100% on measuring the coils - do they need to be in car running, or can they be independently tested for example. Plugs are okay? You can use an OBD2 scanner for some basic checks. I use a bluetooth one with Torque that allows you to add an initialization string with the settings needed for ...
by wenguin
Sun May 24, 2015 1:18 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

That's an AS200 cluster. Redline, and fuel economy meter give it away. Which would explain the difference in the ECU and the cluster rpms. Thanks for that mate. The fuel economy meter seems to work, weirdly. My immediate thought was mileage, but the mileage has been recorded since it came to Europe...
by wenguin
Sun May 24, 2015 1:09 pm
Forum: Parts for sale
Topic: Tons of rare Altezza parts!
Replies: 12
Views: 1657

Re: Tons of rare Altezza parts!

pm'ed
by wenguin
Fri May 22, 2015 3:31 pm
Forum: Car chat
Topic: Mechanics in Northern Ireland to work on Altezza?
Replies: 0
Views: 488

Mechanics in Northern Ireland to work on Altezza?

Hi guys Looking to get a mechanic to change my timing belt and water pump - called a couple of places (Pitstop and MotorTec) but neither would do it - not sure if they just don't do timing belts, or if it is because it's an import. Labour only, I already ordered parts off Nick! Must be in Northern I...
by wenguin
Fri May 22, 2015 1:50 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

Odd, as you can see in the photo of my cluster, the redline appears at about 6250 - I assumed you couldn't go into it due to rev limiter?
by wenguin
Thu May 21, 2015 1:41 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

By the way, I found that following the ECU reset procedure on NZ club (pulling the fuses) didn't work on mine and so I generally leave the battery disconnected overnight instead. I'd also be interested in the coil pack test procedure (just as an extra health check). I know one was replaced in previ...
by wenguin
Wed May 20, 2015 11:15 pm
Forum: Wanted
Topic: Backbox - TRD or other quiet performance box
Replies: 6
Views: 819

Re: Backbox - TRD or other quiet performance box

bump, anything?
by wenguin
Wed May 20, 2015 9:00 pm
Forum: Parts for sale
Topic: TRD Shock Absorbers & Springs
Replies: 4
Views: 525

Re: TRD Shock Absorbers & Springs

did they sell?
by wenguin
Wed May 20, 2015 5:55 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

try calibrating the ecu again.. i use tech stream software to reset mine.. Hi Sil, I don't have anything for editing the ECU unfortunately, just a peasant-tier OBD2 scanner (and it's stock ECU so not sure how much I could edit electronically?) As Tom says, perform a reset and drive it for a bit and...
by wenguin
Tue May 19, 2015 3:51 am
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

Bear in mind its fly by wire. You have to take the airbox off and push the butterfly by hand to get it to fully open, that's why you get such a low full throttle voltage. If you do adjust it, reset the ecu. I adjusted mine and revs jumped to 4k! had to reset the ecu then give it a couple days drivi...
by wenguin
Sun May 17, 2015 10:14 pm
Forum: Member's Cars / Projects
Topic: Finally....An Altezza :)
Replies: 5
Views: 1168

Re: Finally....An Altezza :)

Hi mate, you said in your thread on my.is that you got a working throttle body off someone called BeamsTezza - he a breaker or something? Having TB/idle issues myself, was wondering if you could point me in his direction and also to know if you ever established the source of your problem? Also, love...
by wenguin
Sun May 17, 2015 5:31 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

Alright, possibly big update. OBD2 TPS % @ engine off, throttle closed = 15.3% OBD2 TPS % @ engine off, throttle fully open = 82.4% OBD2 TPS % @ engine on, warmed up, throttle closed = 13.3% (revs @ 761) OBD2 'timing advance' @ engine on, warmed up = 19.0 TPS - can anyone tell if it's been adjusted?...
by wenguin
Sat May 16, 2015 9:37 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

http://z4.invisionfree.com/lexusaltezzaclub/index.php?showtopic=8980 I assume the auto would be the same voltages Cheers, I'll give that a go tomorrow. I've read that the factory TPS screws have yellow paint markings so you can tell if they've been adjusted at any point, hopefully I can get some in...
by wenguin
Sat May 16, 2015 7:20 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Re: Low idle when warm - MAF and TB cleaned - TPS broken?

Edit: I Used the OBD2 scanner to check the Throttle position and it gave a reading of 13.X - I understand it should be 14.8 +/- 0.8 ? Perhaps someone has messed with the adjuster?

I'm hesitant to rely on the OBD2 data - there is a possibility it is wrong I suppose?
by wenguin
Sat May 16, 2015 6:46 pm
Forum: Engine & Transmission section
Topic: Low idle when warm - MAF and TB cleaned - TPS broken?
Replies: 29
Views: 2436

Low idle when warm - MAF and TB cleaned - TPS broken?

Hi guys New RS200 owner, 99 auto. When the car warms up, the idle sits on the tachometer at about 500 and the engine is hesitant. From googling, I see this is a fairly common problem. I've cleaned the MAF and cleaned out the throttle body, but it still exists. Now, I have an OBD2 scanner hooked up a...

Go to advanced search