Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Search found 579 matches

Go to advanced search

by peter0991
Mon Feb 13, 2012 10:02 pm
Forum: Problems with your Altezza
Topic: engine light comes on at 120km/h
Replies: 10
Views: 624

Re: engine light comes on at 120km/h

My engine was cutting out while driving along. Had a look in the throttle body and that was very filthy. Maybe worth cleaning that if you havent yet.
by peter0991
Mon Feb 13, 2012 9:53 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

hursty wrote:Aghhh i was hoping for a " hursty ur a altezza guru" haha !


Haha, not all hope is lost :lol: if changing the MAF resolves the problem you will be getting my thanks. If not.... well i dont want to think about that right now
by peter0991
Mon Feb 13, 2012 9:38 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

The same light bulb also came on with me a few times :D :D . Ive always had an arrow drawn on the maf pointing it the right way, so unfortunately thats not the problem
by peter0991
Mon Feb 13, 2012 9:30 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

tomo wrote:Could possibly be you're maf but readings sound about right, from memory I think it's sposed to be about 0.6-0.8V at idle and 4.3-4.6V at full throttle.


mmmm, mine is showing 0.6-0.8V with the engine switched off :?
by peter0991
Mon Feb 13, 2012 9:27 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

Yes, the plugs were all the same color. The injectors were the next to be upgraded until all these problems began :( But i normally never let the duty go up above %85. The maximum i have had it is around 95% but that was under high load and high revs. There is a guy selling stock injectors which i t...
by peter0991
Mon Feb 13, 2012 8:55 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

Im gonna get another maf sensor and see how that goes. Really hope it will sort the problem out. Thanks for all the advice buddy, will let you know how it goes.
by peter0991
Mon Feb 13, 2012 8:11 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

And if the fuel pump was on its way out it would go lean not rich , as the pump just wouldnt pump enough fuel but the pressure reg is in the pump so no it wouldnt use the injector duty to make up lost pressure The reg will only send down a certain pressure of fuel , so if the pump was down it would...
by peter0991
Mon Feb 13, 2012 8:08 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

I know what u mean... The lambda sensor , the maf , and the coolant temp sensor , but the only one that would open the injectors Like that is the maf , I would say its the maf to be honest , have u still got the cel light on ? The coolant temp sensor is fine, ive got another one running parallel ou...
by peter0991
Mon Feb 13, 2012 7:58 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

What are the main sensors responsible for the fuel mixture?
Also what would happen if the fuel pump is on its way out, could the system try to compensate by increasing injector duty to make up for lower pressure in the fuel rail?
by peter0991
Mon Feb 13, 2012 7:27 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

hursty wrote:Did this happen after u done what u said above ?


:D Some confusion here. The only thing i have done so far is change the spark plugs and clean the maf and throttle body.
by peter0991
Mon Feb 13, 2012 6:59 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Re: Injector duty very high, engine running too rich (3SGE+T

Yes, i have found a maf in the area, will pick it up midweek. Does anyone have a power fc and could possibly tell me the voltage values they are getting at idle. I am getting around 1.6v at 850rpm. I really hope its something as simple as the maf glitching.
by peter0991
Mon Feb 13, 2012 6:06 pm
Forum: Problems with your Altezza
Topic: Injector duty very high, engine running too rich (3SGE+T)
Replies: 61
Views: 5871

Injector duty very high, engine running too rich (3SGE+T)

Hey guys, I am currently having a problem with my engine. It all started last week when my car would not idle properly. The revs were all over the place and the car was stalling constantly. Even when driving along the engine would cut out for a few seconds and the engine light would come on, then th...
by peter0991
Sat Feb 04, 2012 3:55 pm
Forum: Problems with your Altezza
Topic: MOT Fail - Very very very high CO levels
Replies: 22
Views: 1862

Re: MOT Fail - Very very very high CO levels

The car no longer cuts out while driving so thats a bit of an improvement. When pulling away i decided to give it some and the engine light came on at around 6k rpm. And cloud of black smoke came out of the exhaust. The power fc showed the injector duty at 100%. While driving along it still hesitate...
by peter0991
Sat Feb 04, 2012 2:43 pm
Forum: Problems with your Altezza
Topic: MOT Fail - Very very very high CO levels
Replies: 22
Views: 1862

Re: MOT Fail - Very very very high CO levels

Installed new spark plugs today, new lambda sensor, cleaned the maf and throttle body. Was a fair bit of oil in the throttle body. Idle became much better. Pulled the coils out one at a time and each one made the engine idle much rougher. Although after a little drive the spark plugs became caked in...
by peter0991
Fri Feb 03, 2012 8:35 am
Forum: Problems with your Altezza
Topic: MOT Fail - Very very very high CO levels
Replies: 22
Views: 1862

Re: MOT Fail - Very very very high CO levels

Had another problem this morning. Started my car up in the morning and it didn't want to idle. The revs were all over the place. Going from nearly stalling to revving upto 1500. It was about -5 outside and one of my work colleagues suggested ice build up on the maf. I unplugged the maf and the revs ...

Go to advanced search