ImageGreetings! Welcome to Tezzaworld website, unfortunately you are a few years late to the show as nearly everyone has been and gone, there is still lots of useful archived material to read through, not many active users unfortunately, but that’s the way it goes, hopefully you are not too disappointed...

Search found 3 matches

Go to advanced search

by louisq90
Fri Apr 01, 2016 10:16 am
Forum: Engine & Transmission section
Topic: Idling issue
Replies: 4
Views: 828

Re: Idling issue

Yes, that was the first thing i checked because many people were having the issue. I adjusted it to .78.
When i disconnect the MAF sensor the idle issue goes away and runs fine.
by louisq90
Fri Apr 01, 2016 8:29 am
Forum: Engine & Transmission section
Topic: Idling issue
Replies: 4
Views: 828

Idling issue

Good afternoon, Im having an issue with my 99 Altezza. Altezza idle jumps around when at idle temperature. * Clean the MAF & throttle body * Tested Coils * New timing belt and water pump * Good Fuel pump and filter * Checked fuel injectors * No vacuum leaks * Tested Coolant temp sensor Weird thi...
by louisq90
Thu Oct 16, 2014 11:20 am
Forum: Problems with your Altezza
Topic: Issues when braking?
Replies: 0
Views: 551

Issues when braking?

Does anyone else have issues when breaking? when i go over 15 MPH and i press on the brakes i hear a knocking sound under the vehicle. The strange noise only occur when I'm braking. -I have no issues when I'm driving or steering. -Steering does not shake when brakes are applied. -I put my car on a l...

Go to advanced search