Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Search found 6 matches

Go to advanced search

by Tezza Jordan
Fri Jun 14, 2013 1:46 am
Forum: Problems with your Altezza
Topic: Rev Limiting at 6000rpm
Replies: 9
Views: 1398

Re: Rev Limiting at 6000rpm

Ya it kicks in every tine at 4000 4500 and keeps goin until 6 and no more then car limits unless i change gear..being honest im nt 2 sure when it started doing this as i dnt drive the car hard just gave it a blast 5 6weeks ago and spotted it!!!!nt sur ie da ecu has a limp mode how would i check
by Tezza Jordan
Thu Jun 13, 2013 12:38 pm
Forum: Problems with your Altezza
Topic: Rev Limiting at 6000rpm
Replies: 9
Views: 1398

Re: Rev Limiting at 6000rpm

Car is hitting vvti no problem but the car is limiting at 6000 redline on clocks is a 8000.realy dnt kno wats after happening :( :( :(
by Tezza Jordan
Wed Jun 12, 2013 8:15 pm
Forum: Problems with your Altezza
Topic: Rev Limiting at 6000rpm
Replies: 9
Views: 1398

Rev Limiting at 6000rpm

Hi guys my car is now limiting at 6000rpm every gear. Does anyone know the issue here or even better a solution.Advice is greatly appreciated!!!!
by Tezza Jordan
Sat May 18, 2013 11:59 am
Forum: Engine & Transmission section
Topic: blitz supercharger
Replies: 14
Views: 2182

Re: blitz supercharger

Sorry now mate im no help to you but i want to supercharge my car!!!!!Just wondering if any1 knows where i mite buy 1 or has anybody got 1 for sale :D :D :D
by Tezza Jordan
Thu Mar 07, 2013 1:28 pm
Forum: Problems with your Altezza
Topic: altezza Miss Firing at 5000Rpm at full throtte
Replies: 9
Views: 651

Re: altezza Miss Firing at 5000Rpm at full throtte

Cheers Wullie.Seems to be a common accurance with people!!!!!will let ye kno how it fairs out :mrgreen: :mrgreen:
by Tezza Jordan
Thu Mar 07, 2013 10:58 am
Forum: Problems with your Altezza
Topic: altezza Miss Firing at 5000Rpm at full throtte
Replies: 9
Views: 651

Re: altezza Miss Firing at 5000Rpm at full throtte

Hi lads just joined the site.Im having the same issue but at 4000Rpm.I cleaned out the MAF sensor any other ideas :) !!!!!

Go to advanced search