Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Search found 11 matches

Go to advanced search

by skn869
Sat Sep 05, 2015 12:31 am
Forum: Problems with your Altezza
Topic: engine wont start
Replies: 0
Views: 819

engine wont start

hey guys i just install a new beam 3sge engine but i haven't plugged in the o2 sensor , could it be thats the reason why its not starting ?
by skn869
Mon Jul 28, 2014 9:31 pm
Forum: Engine & Transmission section
Topic: 3sge engine build
Replies: 6
Views: 1270

3sge engine build

hey guys, i want to get at least 300-320hp in my altezza without turbo charging it.. can anyone help me out with a engine mod list, what upgrades need to be done etc?
by skn869
Fri Mar 14, 2014 1:27 am
Forum: Problems with your Altezza
Topic: problem after installing cold air intake
Replies: 13
Views: 2068

Re: problem after installing cold air intake

think i'll take it off and weld in the fins
tezza mod 2.jpg
my altezza mod.... hope i can solve the problem soon
tezza mod 2.jpg (129.32 KiB) Viewed 1916 times
by skn869
Fri Mar 14, 2014 1:13 am
Forum: Problems with your Altezza
Topic: problem after installing cold air intake
Replies: 13
Views: 2068

Re: problem after installing cold air intake

the fins are not weld in as yet.. it was a direct flow pipe.. i went the cheap way because the hks types are very expensive... i bought the intake thats for the 6cylinder altezza/is300 and cut the pipe to make it work on my 3sge engine
by skn869
Fri Mar 14, 2014 1:09 am
Forum: Problems with your Altezza
Topic: problem after installing cold air intake
Replies: 13
Views: 2068

Re: problem after installing cold air intake

hey guys, it is a automatic.... i clean the maf sensor etc,..... i found out in the stock air intake box where the sensor is install on the inside there are 2 fins, i guess they are there to reduce air turbulance to the maf sensor so i got to pieces of sheet metal and make a 2 temporary fins, place ...
by skn869
Thu Feb 13, 2014 2:32 am
Forum: Problems with your Altezza
Topic: problem after installing cold air intake
Replies: 13
Views: 2068

problem after installing cold air intake

hey there, i just recently install a cold air intake + oil catch can on my N/A Altezza after installing and resetting my ECU, i start the car for the computer to learn the little mod i did to the engine... while taking the car for a test run the car seems to be flattering .. what could be the proble...
by skn869
Fri Feb 22, 2013 12:28 pm
Forum: Member's Cars / Projects
Topic: Problem with my altezza
Replies: 3
Views: 516

Re: Problem with my altezza

Het guys, i solve the problem. My catalytic was blocked up so thats what was causing my coil pack to go bad
by skn869
Fri Dec 14, 2012 3:07 am
Forum: Member's Cars / Projects
Topic: Problem with my altezza
Replies: 3
Views: 516

Problem with my altezza

Hey guys I have develop a problem with my car. One night I started my car to go for a drive, it started well and driving well . While driving I came up to a car about to overtake it then suddenly I realized the car didn't had full power and sounded very strange ( sounded like a subaru ) . Had a mech...
by skn869
Tue Oct 02, 2012 4:12 pm
Forum: Member's Cars / Projects
Topic: My Altezza
Replies: 2
Views: 325

Re: My Altezza

thank u
by skn869
Tue Oct 02, 2012 3:35 pm
Forum: Member's Cars / Projects
Topic: My Altezza
Replies: 2
Views: 325

My Altezza

:D

Go to advanced search