Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Search found 22 matches

Go to advanced search

by MacRS200
Sun Mar 04, 2012 5:21 pm
Forum: Problems with your Altezza
Topic: Dash stops working and Limp mode ?
Replies: 3
Views: 717

Re: Dash stops working and Limp mode ?

I had the same before and it turned out to be a dodgy windscreen replacement was letting water in at the N/S A pillar. The water made it's way, as it does, into the passenger footwell fuse box. Took it out and cleaned the the corroded contacts, put it all back together and the problem was gone If yo...
by MacRS200
Sun Mar 04, 2012 4:43 pm
Forum: Problems with your Altezza
Topic: Should the engine run with MAF disconnected
Replies: 2
Views: 385

Should the engine run with MAF disconnected

Hi all not been on here for a long time and as usual back because of problems :) Been having problems with the Tezza being sluggish and not responding to the throttle as it should. Managed to get the MAF out, long story, and gave it a clean up. Now much better but still not right. While working on i...
by MacRS200
Tue Apr 14, 2009 8:19 am
Forum: Problems with your Altezza
Topic: Broke down!
Replies: 61
Views: 3859

Re: Broke down!

Sounds not too bad, relatively, then Noel. Set of valves then.

Are the valve guides OK?
by MacRS200
Thu Apr 02, 2009 9:13 pm
Forum: Problems with your Altezza
Topic: Pulling to one side while accelerating
Replies: 33
Views: 2614

Re: Pulling to one side while accelerating

Well glad you got sorted.

Call me Thicky McThick but I can't see how a <3% difference in rolling radius could cause a "violent pull" under acceleration. Assuming that you have no wheel spin on one side.
by MacRS200
Mon Mar 09, 2009 3:00 pm
Forum: Brakes and Suspension
Topic: Rear bushings?
Replies: 12
Views: 5474

Re: Rear bushings?

Just got mail back from Nick they can only be got with the hub... Lanigan, I will let ya know....MacRS200 if you have a link for where you bought yours can you put it up please thanks.... Ended up going to Lexus as I couldn't find a pattern axle carrier. Blueprint do a bearing but not much cheaper ...
by MacRS200
Sun Mar 08, 2009 6:24 pm
Forum: Brakes and Suspension
Topic: Rear bushings?
Replies: 12
Views: 5474

Re: Rear bushings?

Don't know if the bush will press out or not, if it will and a Renault one will fit that would be a right result! Let us know if it does and the part number if you can get it. I just done one of them and you need to buy the whole axle carrier £ 140 plus the bearing as it won't press out without dest...
by MacRS200
Sun Mar 08, 2009 10:31 am
Forum: Brakes and Suspension
Topic: Rear bushings?
Replies: 12
Views: 5474

Re: Rear bushings?

Are you sure it's not the one shown in red below? This is the usual one to go. Its on the axle carrier at the outside end of the lower suspension arm.

Image
by MacRS200
Sat Feb 28, 2009 10:46 pm
Forum: Problems with your Altezza
Topic: Pulling to one side while accelerating
Replies: 33
Views: 2614

Re: Pulling to one side while accelerating

KaTaLy5t wrote:If there was something wrong with one side of the diff and more power was going to one side it would pull the car to one side.

Diff is mechanical and runs through gears so still don't see how more torque could go to one side if the car is going straight.

Worn bush is what you got IMHO.
by MacRS200
Sat Feb 28, 2009 5:14 pm
Forum: Problems with your Altezza
Topic: Pulling to one side while accelerating
Replies: 33
Views: 2614

Re: Pulling to one side while accelerating

Had exactly this on the IS and it was a knackered bush, wheel moves forward slightly when you accelerate causing toe in. This changes the trust angle away from the dodgy wheel. So N/S knackered will cause the car to pull right under acceleration. Only fix is a new axle carrier and wheel bearing I'm ...
by MacRS200
Mon Oct 27, 2008 10:23 pm
Forum: Pic & video vault
Topic: Clever Pic
Replies: 11
Views: 694

Top one, great pic :lol:
by MacRS200
Wed Oct 22, 2008 6:10 pm
Forum: Problems with your Altezza
Topic: Rev Counter and Oil Pressure gauge not working
Replies: 3
Views: 754

Thanks guys, need to start a wiring check up then I suppose.
by MacRS200
Wed Oct 22, 2008 10:52 am
Forum: Brakes and Suspension
Topic: anyone got greenstuff pads on????
Replies: 8
Views: 717

I've had standard, Greenstuff and Mintex on mine. Greenstuff and Mintex both have a bit more "bite" than standard but all round I would go for the Mintex. They are every bit as good as the Greenstuff, last longer and cost less. Oh and as asked they are the same size as the IS200, IS300 AND...
by MacRS200
Tue Oct 21, 2008 8:25 pm
Forum: Problems with your Altezza
Topic: Rev Counter and Oil Pressure gauge not working
Replies: 3
Views: 754

Rev Counter and Oil Pressure gauge not working

Hi to all on the Emerald Isle, posted this over on LOC as well. Really should visit here more often and not be so cheeky to only post when I got a problem but I know you are all nice guys on here :wink: Drove the car this morning and I didn't notice anything amiss as the drive is short, lots of junc...
by MacRS200
Tue Oct 21, 2008 8:17 pm
Forum: Problems with your Altezza
Topic: HELP : Engine Check light On
Replies: 18
Views: 4023

Agree with all of the above plus the VVTi will be able to correct the valve timing up to the point where it goes "out of range".

So take it back and get the timing checked.
by MacRS200
Thu Mar 15, 2007 12:17 am
Forum: Car chat
Topic: Varis Carbon bonnet weights
Replies: 9
Views: 3435

Take the sound insulation off and that will get rid of about 10Kg I would reckon.

Go to advanced search