Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Search found 25 matches

Go to advanced search

by not_too_fast
Mon Nov 22, 2010 11:39 pm
Forum: Problems with your Altezza
Topic: Broken again
Replies: 40
Views: 5558

Re: Broken again

you heard tapping?

big ends gone....?
by not_too_fast
Sun Nov 14, 2010 10:36 pm
Forum: Engine & Transmission section
Topic: How to take the head off the 3sge?
Replies: 1
Views: 312

How to take the head off the 3sge?

As above would be usefull for a bit of info on this.. mad to have a go at it.
by not_too_fast
Sun Nov 14, 2010 10:34 pm
Forum: Engine & Transmission section
Topic: GREDDY TURBO KIT MAX BOOST ?
Replies: 16
Views: 3630

Re: GREDDY TURBO KIT MAX BOOST ?

you need a power fc or an emanage os of coarse it can be mapped and has to be mapped... it can't run right on a standard ECU!!
by not_too_fast
Sun Nov 14, 2010 5:16 pm
Forum: Engine & Transmission section
Topic: GREDDY TURBO KIT MAX BOOST ?
Replies: 16
Views: 3630

Re: GREDDY TURBO KIT MAX BOOST ?

i wouldn't have even bought it if it wasn't mapped right..
by not_too_fast
Tue Oct 19, 2010 8:20 pm
Forum: Problems with your Altezza
Topic: power enterprise supercharger isuue
Replies: 14
Views: 1300

Re: power enterprise supercharger isuue

yup, i have a blitz set up in my yoke..

check the alternator belt too

must you put oil in the compressor u have?
by not_too_fast
Tue Oct 19, 2010 7:14 pm
Forum: Problems with your Altezza
Topic: power enterprise supercharger isuue
Replies: 14
Views: 1300

Re: power enterprise supercharger isuue

boost in my car drops as well once ya get over 5k rpm... think thats normal, but not so that it starts a vaccum at 7k rpm

what pulley have you on the s/c? it could be from belt slippage...
by not_too_fast
Tue Oct 19, 2010 5:05 pm
Forum: Problems with your Altezza
Topic: power enterprise supercharger isuue
Replies: 14
Views: 1300

Re: power enterprise supercharger isuue

Did you upgrade the injectors?
could be runnig too lean?
by not_too_fast
Sun Oct 17, 2010 10:35 pm
Forum: Member's Cars / Projects
Topic: Maybe a Supercharged Turbo Altezza in the making??
Replies: 3
Views: 579

Maybe a Supercharged Turbo Altezza in the making??

Right had a tip out the county bounds at the weekend. Hit a ditch fairly straight on and here's the damage before and after i took off the throttle body, air intake piping, intercooler and piping... and rads... http://i601.photobucket.com/albums/tt93/benomac_album/th_Photo0044.jpg http://i601.photob...
by not_too_fast
Sat Oct 09, 2010 2:47 am
Forum: Problems with your Altezza
Topic: Could this be my problem?
Replies: 2
Views: 359

Re: Could this be my problem?

yup thats the one..
by not_too_fast
Fri Oct 08, 2010 6:22 pm
Forum: Problems with your Altezza
Topic: Could this be my problem?
Replies: 2
Views: 359

Could this be my problem?

Right after checking all the sensors that could be causing my car to run rich, i went at the throttle body and found that the thermostat in that wasn't connected and i cant find the wires to it :shock: Im thinkin because its right above the s/c that when a belt snapped that it broke it off and the p...
by not_too_fast
Thu Oct 07, 2010 3:01 pm
Forum: Problems with your Altezza
Topic: coolant tempeture sensor..
Replies: 4
Views: 460

Re: coolant tempeture sensor..

think i know where that is.. .

your a legend, thanks a million :D
by not_too_fast
Thu Oct 07, 2010 2:37 pm
Forum: Problems with your Altezza
Topic: coolant tempeture sensor..
Replies: 4
Views: 460

Re: coolant tempeture sensor..

thats a thermostat, its a coolant temp sensor im lookin for..they are two diff things
cheers anyway!
by not_too_fast
Thu Oct 07, 2010 1:03 pm
Forum: Problems with your Altezza
Topic: coolant tempeture sensor..
Replies: 4
Views: 460

coolant tempeture sensor..

where is this? :?
by not_too_fast
Mon Oct 04, 2010 9:53 am
Forum: Problems with your Altezza
Topic: PCV valve
Replies: 3
Views: 978

Re: PCV valve

nothing is connected to it and it won'y connect to it cause it looks lik its damaged
by not_too_fast
Sun Oct 03, 2010 10:41 pm
Forum: Problems with your Altezza
Topic: PCV valve
Replies: 3
Views: 978

PCV valve

...just noticed its not connected to my rocker cover.

could this be the reason its running so rich, burning so much oil and is running s@3!!?

Go to advanced search

cron